Author Topic: Some time SMB not Optimized !  (Read 1957 times)

Sazgar

  • Member
  • ***
  • Posts: 10
    • View Profile
Some time SMB not Optimized !
« on: January 22, 2018, 12:27:33 PM »
Hi

I am testing this product (wanos  4.2.1 64bit plus 20/200)
And I realized when transferring files using SMB protocol (File Sharing On Windows)
In some cases, no optimization is done and all the traffic was bypassed (Pass-through)
and some cases all the traffic was optimized

is it normal ? or some thing wrong here ?

Thanks
« Last Edit: January 23, 2018, 11:05:48 AM by Sazgar »
MCSA Security 2003
MCSA 2008

lmolina

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 24
    • View Profile
Re: Some time SMB not Optimized !
« Reply #1 on: January 22, 2018, 12:40:45 PM »
Hello Sazgar,

Have a look at http://wanos.co/docs/docs/wanos-admin-guide/configuration/optimization-setting/ more specifically "Peer Timeout". Depending on your network traffic, you may adjust the timeout to be either longer or shorter. Let us know if that helped.
MCP

Note: Forum posts may be outdated. Please see wanos.co/docs for more recent info.

ahenning

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 625
    • View Profile
Re: Some time SMB not Optimized !
« Reply #2 on: January 22, 2018, 02:09:57 PM »
If after a config change, and depending on which config change, that would be the normal expected behavior. By default Wanos does not reset TCP sessions when making a config change. This can be enabled by enabling the TCP-X Accelerator.

SMB/CIFS sessions are cached and remain open for a long time, avoiding a TCP handshake. Due to this after a config change on Wanos, the CIFS/SMB TCP session needs to be reset either by Wanos with TCP-X or on the PC/Server.
CCIE RS, CCIE SP, Mnet&sys

Note: Forum posts may be outdated. Please see the latest documentation at wanos.co/docs

Sazgar

  • Member
  • ***
  • Posts: 10
    • View Profile
Re: Some time SMB not Optimized !
« Reply #3 on: January 22, 2018, 03:11:33 PM »
If after a config change, and depending on which config change, that would be the normal expected behavior. By default Wanos does not reset TCP sessions when making a config change. This can be enabled by enabling the TCP-X Accelerator.

SMB/CIFS sessions are cached and remain open for a long time, avoiding a TCP handshake. Due to this after a config change on Wanos, the CIFS/SMB TCP session needs to be reset either by Wanos with TCP-X or on the PC/Server.


Hi ahenning
thanks for your explain.
But between file transfers, I did not make any changes to the configuration (Nothing )

I transferred a 10MB file for first time, and traffic up to 90% optimized

After about 8 minutes, I transferred the same file again, but the optimization was 0% and all traffic was bypassed (Pass-through)
and for third time, After about 5 minutes, I transferred the same file again, and no optimization is done and all the traffic was bypassed


(During the transfer of the second and third filesو I checked the "Peer Timeout" and was "Idel")

:(
MCSA Security 2003
MCSA 2008

Sazgar

  • Member
  • ***
  • Posts: 10
    • View Profile
Re: Some time SMB not Optimized !
« Reply #4 on: January 22, 2018, 03:16:14 PM »
Hello Sazgar,

Have a look at http://wanos.co/docs/docs/wanos-admin-guide/configuration/optimization-setting/ more specifically "Peer Timeout". Depending on your network traffic, you may adjust the timeout to be either longer or shorter. Let us know if that helped.

Thanks
I changed from 60 to 180 in both sides, but apparently the problem did not resolve.

MCSA Security 2003
MCSA 2008

ahenning

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 625
    • View Profile
Re: Some time SMB not Optimized !
« Reply #5 on: January 22, 2018, 05:29:25 PM »
Hi,

Yes, please use Lew's suggestion. Increase it even more at say 900 seconds as this is lab testing setup and it seems there is not enough traffic in the lab to keep the peers active. Once the peer timeout has been increased and all configuration on Wanos has been completed and no-additional changes are expected, reboot the Microsoft workstation or server to force the TCP session to re-establish.
CCIE RS, CCIE SP, Mnet&sys

Note: Forum posts may be outdated. Please see the latest documentation at wanos.co/docs

Sazgar

  • Member
  • ***
  • Posts: 10
    • View Profile
Re: Some time SMB not Optimized !
« Reply #6 on: January 22, 2018, 09:01:14 PM »
thanks again
The problem was solved, the SMB  traffic is well optimized.

But in the next test, I have a similar problem with HTTP, FTP, HTTPS protocols.
All these traffic was bypassed (Pass-through).

Should I make new traffic policies? :-\


(HTTP traffic result attached)
« Last Edit: January 23, 2018, 11:06:13 AM by Sazgar »
MCSA Security 2003
MCSA 2008