Author Topic: Force speed and duplex  (Read 1588 times)

antunafr

  • VIP
  • Member
  • ***
  • Posts: 6
    • View Profile
Force speed and duplex
« on: May 02, 2017, 01:39:29 PM »
Hello everybody, this is my first post. First of all, thanks the Wanos team for the great job.

I'm setting up a Wanos 300 appliance and I need to force speed and duplex of my WAN interface to 100/full.
I have not found where I can do that at the web interface. Maybe it is not possible ?

Could anyone explain me which is the preferred way to modify speed and duplex settings on a Wanos appliance ?
The software version is 3.2.3 Prod.

Thank you very much in advance.

Regards.



« Last Edit: May 02, 2017, 02:20:05 PM by antunafr »

ahenning

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 625
    • View Profile
Re: Force speed and duplex
« Reply #1 on: May 02, 2017, 02:20:09 PM »
The interfaces are auto-negotiated by default. The recommendation is to try as far as possible to use auto and enable auto negotiation on the switch/router side so that negotiation succeeds.

For the corner cases, when the recommended method is not possible, here is how to set it manually:

Quote
ethtool -s wan0 speed 100 duplex full
ethtool -s lan0 speed 100 duplex full


Once you are happy that the commands work as expected and you want the commands to run automatically after reboots etc, then add them to /etc/wanos/ethtool_options file e.g.:

Quote
ETHTOOL_OPTS_WAN0=speed 100 duplex full autoneg off


We'll usually do something like this for the client remotely, but you can run them, just make absolutely sure there aren't typos in the line.
« Last Edit: March 04, 2019, 09:25:21 AM by ahenning »
CCIE RS, CCIE SP, Mnet&sys

Note: Forum posts may be outdated. Please see the latest documentation at wanos.co/docs

antunafr

  • VIP
  • Member
  • ***
  • Posts: 6
    • View Profile
Re: Force speed and duplex
« Reply #2 on: May 02, 2017, 02:26:13 PM »
Hi ahenning,

Thank you very much. That's exactly what I need.

In fact, for your information, I can't use autonegociation because my WAN interface is connected to a telecom operator device and I can't change its configuration.

Thank you again.

Regards.