Author Topic: Install to ESXi 4.1  (Read 3904 times)

samuelhk

  • Member
  • ***
  • Posts: 4
    • View Profile
Install to ESXi 4.1
« on: May 16, 2016, 10:12:43 AM »
Hi,

Is it possible to install wanos 3.0 to ESXi 4.1? The existing OVF file is for 5.1 or above. Thanks.

ahenning

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 629
    • View Profile
Re: Install to ESXi 4.1
« Reply #1 on: May 16, 2016, 10:44:51 AM »
Hi,

Rename wanos-3.0.1.ova to wanos-3.0.1.rar
Inside the archive will be the vmdk file.

Use the .vmdk file to create the ESXi 4.1 virtual machines. Recommended method for 4.1

Another option. After extracting the OVA edit the wanos-3.0.1.ovf file and change the type to vmx-07 e.g.
<vssd:VirtualSystemType>vmx-07</vssd:VirtualSystemType>
Also update the checksums in the .mf file.

Or use the ovftool to convert from OVA to OVF.
« Last Edit: May 16, 2016, 11:19:52 AM by ahenning »
CCIE RS, CCIE SP, Mnet&sys

Note: Forum posts may be outdated. Please see the latest documentation at wanos.co/docs

samuelhk

  • Member
  • ***
  • Posts: 4
    • View Profile
Re: Install to ESXi 4.1
« Reply #2 on: May 18, 2016, 06:39:09 AM »
Hi,

I'm able to convert the vm to version 7 by vmware converter. But when I boot up the guest in ESXi 4.1. A message show up and cannot continue the boot process. How to fix it?

Message:
This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot - please use a kernel appropriate for your CPU.

ahenning

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 629
    • View Profile
Re: Install to ESXi 4.1
« Reply #3 on: May 18, 2016, 07:40:50 AM »
It could be the Guest OS Setting. Please have a look at this setting:

CCIE RS, CCIE SP, Mnet&sys

Note: Forum posts may be outdated. Please see the latest documentation at wanos.co/docs

samuelhk

  • Member
  • ***
  • Posts: 4
    • View Profile
Re: Install to ESXi 4.1
« Reply #4 on: May 18, 2016, 08:31:03 AM »
Hi,

The option won't work. Our testing server is a bit old but the CPU is 64bit.

http://ark.intel.com/products/27083/64-bit-Intel-Xeon-Processor-3_20E-GHz-2M-Cache-800-MHz-FSB

ahenning

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 629
    • View Profile
Re: Install to ESXi 4.1
« Reply #5 on: May 18, 2016, 10:37:22 AM »
Hi,

Ok, a basic 32-bit vmx7 image is available at http://wanos.co/updateinfo/wanos-3.0.1-vmx7.zip
It is in ovf format. Please configure the NIC interfaces after importing to ESX
CCIE RS, CCIE SP, Mnet&sys

Note: Forum posts may be outdated. Please see the latest documentation at wanos.co/docs

samuelhk

  • Member
  • ***
  • Posts: 4
    • View Profile
Re: Install to ESXi 4.1
« Reply #6 on: May 19, 2016, 03:20:22 PM »
Finally, the wanos was installed in our ESXi 4.1. I can start the testing. Many Thanks.

ahenning

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 629
    • View Profile
Re: Install to ESXi 4.1
« Reply #7 on: May 19, 2016, 03:27:00 PM »
Pleasure,

Also before testing, first update:

wget http://wanos.org/updateinfo/update-3.0.3.sh
wget http://wanos.org/updateinfo/update-3.0.3.tar.gz
bash update-3.0.3.sh update

CCIE RS, CCIE SP, Mnet&sys

Note: Forum posts may be outdated. Please see the latest documentation at wanos.co/docs