Author Topic: Out-of-Path Options  (Read 4050 times)

Wanos

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 56
    • View Profile
Out-of-Path Options
« on: March 04, 2014, 09:17:45 AM »
Two out of path deployment options are available.

Router mode:
PBR Pros: Network transparency. High Availability - Immediate seamless fail-over. More efficient, less overhead. More robust.
PBR Cons: Router needs to be configured to PBR traffic to the Core.


Tunnel mode:
Tunnel Pros: Simpler, no need to configure any routing for the incoming traffic from the WAN.
Tunnel Cons: More overhead. Transparency is lost in the WAN.
« Last Edit: September 22, 2015, 11:17:56 AM by ahenning »
Note: Forum posts may be outdated. Please see the latest documentation at wanos.co/docs

Wanos

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 56
    • View Profile
Re: Out-of-Path Options
« Reply #1 on: March 18, 2014, 01:24:18 PM »
PBR: Either a Router or Layer 3 switch is used to direct traffic from the lan to the virtual lan0 address. Return traffic from the wan is redirected to the wan0 addressl. Fail-over is achieved with an IP SLA tracking feature. During failover or maintenance for example, tracking removes the route policy.



Example Config:

ip sla 1
icmp-echo 10.0.0.2
frequency 4
ip sla schedule 1 life forever start-time now
!
ip access-list extended lan0
deny ip host 10.0.0.2 any
permit tcp 10.1.1.0/24 192.168.1.0/24
ip access-list extended wan0
permit ip 192.168.1.0/24 10.1.1.0/24
!
route-map lan0
match ip address lan0
set ip next-hop verify-availability 10.0.0.1 1 track 1
!
route-map wan0
match ip address wan0
set ip next-hop verify-availability 10.0.0.2 1 track 1
!
interface fastEthernet0
description LAN
ip policy lan0
interface Serial0
description WAN
ip policy wan0
!



 
In the Router mode, routing can be used to direct traffic from the wan to the wan0 address and traffic from lan to the lan0. It is also possible to set the default gateway to the virtual lan0 addresses.


Example Config:

ip route 10.1.1.0 255.255.255.0 10.0.0.2
ip route 10.2.2.0 255.255.255.0 10.0.0.2
« Last Edit: March 21, 2015, 06:58:20 PM by ahenning »
Note: Forum posts may be outdated. Please see the latest documentation at wanos.co/docs

ahenning

  • Team Wanos
  • Administrator
  • Full Member
  • *****
  • Posts: 625
    • View Profile
Re: Out-of-Path Options
« Reply #2 on: March 10, 2015, 12:15:58 AM »
Router mode and Tunnel mode is now available via the UI.
« Last Edit: September 22, 2015, 11:18:37 AM by ahenning »
CCIE RS, CCIE SP, Mnet&sys

Note: Forum posts may be outdated. Please see the latest documentation at wanos.co/docs