Wan Optimization Support

Technical => Troubleshooting => Topic started by: pwallace10 on March 18, 2016, 08:09:54 AM

Title: WANOS boots to Core Linux
Post by: pwallace10 on March 18, 2016, 08:09:54 AM
I was impressed at first but now I am feeling less enthusiastic, I ran WANOS on a USB, looked at the features and then tried to write it to the physical disk, it failed, from then the machine just boots to the Core Linux.
I tried a new machine and it also booted into WANOS, after trying to write the system to disk it just boots to the Core Linux prompt. The writing to disk also failed.

I noticed that if I unplug the physical hard disk they WANOS boots up again, so what is the failure to write the OS to disk do that it just toasts the system?

I see may people ask the question about how to write the OS to disk but the answers are all the same, is there no better way?

Title: Re: WANOS boots to Core Linux
Post by: pwallace10 on March 18, 2016, 12:09:01 PM
I can answer my own question..

If the writing to disk fails it does something to the destination disk partition table, if that table is not readable then WANOS fails to load even if its loading off the USB disk.

Unplug the physical hard disk and check that WANOS loads normally (just to make sure yours OS Image is not toasted)

Then wipe any partition off the physical hard disk using a USB boot tool and try again. It seems that once you have had one run at it and it fails you HAVE to wipe the destination disk before trying again.

My subsequent tries succeeded even though they did show some errors during the writing process, never the less WANOS loaded and ran off the physical disk.

Most frustrating as the partition issue is not mentioned on any forum and took me the better part of a day to solve.
Hopefully this helps someone else.
Title: Re: WANOS boots to Core Linux
Post by: ahenning on March 18, 2016, 02:24:34 PM
Hi Peter,

The raw disk image has been used to deploy 1000's of devices world wide. It is specifically designed to make it possible to deploy on any whitebox bare metal appliances that don't have a VGA or CDROM available. If there is a better way I would be happy to test it.

As per the post, it seems there are errors during writing to disk. This is a bad sign, since I suspect problems with the hardware later could be possible. Personally I would be hesitant to go into production with a disk that experiences write errors since the byte cache is extremely disk intensive and given enough time, will break a drive already on its way out. Possibly it could also potentially be read errors from the USB that are shown as write errors during the copy.

Other potential issues, that I don't think are relevant but to provide a full answer:

Booting with the USB and physical disk connected with the exact same raw disk image is not recommended. They are two clones of the same drive and problems do occur. After writing to disk, disconnect the USB. Or better and recommended, flash the physical drive with the raw disk image from scratch.

It could be that some RAID and SCSI drives are not compatible with the generic linux drivers. In the case of RAID it sometimes works to disable RAID. Certain SCSI issues can be resolved by running the boot image from another drive and mounting the datastore on the SCSI drivers for better IO.

Another alternative when driver issues are suspected is to use the Ubuntu image instead of the Core Linux image.

If for whatever reason all else fails, VMware ESXi can be loaded on the hardware and Wanos loaded as a VM.

Lastly, all the hassles of installing the software can be avoided with the Wanos appliances.
Title: Re: WANOS boots to Core Linux
Post by: ahenning on May 14, 2016, 02:41:04 PM
Another route worth taking:

When burning the raw disk image to the appliance is not the preferred method, install ESXi as a base and load the Wanos Virtual Machine.